summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/invoker/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-08-09 15:05:52 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-08-09 15:05:52 (GMT)
commit6dce9df7f483f3229bb2f34f0386ce37a1551e07 (patch)
tree1d3acaec4612d74ee3234c808df7ae5fa3b4ef9f /src/uscxml/plugins/invoker/CMakeLists.txt
parent01f8198f8b548e3f28cad1a441ceb8af6ea850a4 (diff)
downloaduscxml-6dce9df7f483f3229bb2f34f0386ce37a1551e07.zip
uscxml-6dce9df7f483f3229bb2f34f0386ce37a1551e07.tar.gz
uscxml-6dce9df7f483f3229bb2f34f0386ce37a1551e07.tar.bz2
Extended Java bindings and OpenAL invoker
Diffstat (limited to 'src/uscxml/plugins/invoker/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/invoker/CMakeLists.txt35
1 files changed, 34 insertions, 1 deletions
diff --git a/src/uscxml/plugins/invoker/CMakeLists.txt b/src/uscxml/plugins/invoker/CMakeLists.txt
index 4f13aaf..e23d65e 100644
--- a/src/uscxml/plugins/invoker/CMakeLists.txt
+++ b/src/uscxml/plugins/invoker/CMakeLists.txt
@@ -3,6 +3,7 @@ file(GLOB_RECURSE SAMPLE_INVOKER
sample/*.cpp
sample/*.h
)
+
source_group("Invoker\\sample" FILES ${SAMPLE_INVOKER})
if (BUILD_AS_PLUGINS)
add_library(
@@ -14,7 +15,6 @@ else()
list (APPEND USCXML_FILES ${SAMPLE_INVOKER})
endif()
-
# DirMon invoker to watch for filesystem changes
file(GLOB_RECURSE DIRMON_INVOKER
@@ -281,7 +281,40 @@ if (OPENSCENEGRAPH_FOUND AND OPENGL_FOUND)
else()
list (APPEND USCXML_FILES ${OPENSCENEGRAPH_CONVERTER_INVOKER})
endif()
+endif()
+
+
+# OpenAL modality components
+
+if (OPENAL_FOUND AND (LIBSNDFILE_FOUND OR AUDIOTOOLBOX_FOUND))
+ file(GLOB_RECURSE OPENAL_INVOKER
+ audio/OpenAL*.cpp
+ audio/OpenAL*.h)
+ if (LIBSNDFILE_FOUND)
+ file(GLOB_RECURSE LIBSNDFILE_WRAPPER
+ audio/LibSoundFile*.cpp
+ audio/LibSoundFile*.h)
+ LIST(APPEND OPENAL_INVOKER ${LIBSNDFILE_WRAPPER})
+ elseif(AUDIOTOOLBOX_FOUND)
+ file(GLOB_RECURSE AUDIOTOOLBOX_WRAPPER
+ audio/AudioToolbox*.mm
+ audio/AudioToolbox*.h)
+ LIST(APPEND OPENAL_INVOKER ${AUDIOTOOLBOX_WRAPPER})
+ endif()
+ source_group("Invoker\\audio" FILES ${OPENAL_INVOKER})
+# message("MILES_INVOKER ${MILES_INVOKER}")
+ if (BUILD_AS_PLUGINS)
+ add_library(
+ invoker_openal SHARED
+ ${OPENAL_INVOKER})
+ target_link_libraries(invoker_openal
+ ${OPENAL_LIBRARY}
+ uscxml)
+ set_target_properties(invoker_openal PROPERTIES FOLDER "Plugin Invoker")
+ else()
+ list (APPEND USCXML_FILES ${OPENAL_INVOKER})
+ endif()
endif()