summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/invoker/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <github@mintwerk.de>2017-01-27 21:54:43 (GMT)
committerStefan Radomski <github@mintwerk.de>2017-01-27 21:54:43 (GMT)
commit7f83038a1ef642b883417cc984d1f8ca9f0bc64b (patch)
treefd9236e866a06b250992e84bbf41324adf93a9fd /src/uscxml/plugins/invoker/CMakeLists.txt
parentb450411ee8f0a57f3ec3909d65ecc289189e2b35 (diff)
downloaduscxml-7f83038a1ef642b883417cc984d1f8ca9f0bc64b.zip
uscxml-7f83038a1ef642b883417cc984d1f8ca9f0bc64b.tar.gz
uscxml-7f83038a1ef642b883417cc984d1f8ca9f0bc64b.tar.bz2
Reactivated BUILD_AS_PLUGINS
Diffstat (limited to 'src/uscxml/plugins/invoker/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/invoker/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/uscxml/plugins/invoker/CMakeLists.txt b/src/uscxml/plugins/invoker/CMakeLists.txt
index 5500e3f..9f50684 100644
--- a/src/uscxml/plugins/invoker/CMakeLists.txt
+++ b/src/uscxml/plugins/invoker/CMakeLists.txt
@@ -6,7 +6,18 @@ if (WITH_INV_SCXML)
file(GLOB_RECURSE USCXML_INVOKER
scxml/*.cpp
scxml/*.h)
+ if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${USCXML_INVOKER})
+ add_library(invoker_uscxml SHARED ${USCXML_INVOKER} "../Plugins.cpp")
+ target_link_libraries(invoker_uscxml
+ uscxml
+ )
+ set_target_properties(invoker_uscxml PROPERTIES FOLDER "Plugins//Invoker")
+ set_target_properties(invoker_uscxml PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(invoker_uscxml PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/lib/plugins")
+ else()
list (APPEND USCXML_FILES ${USCXML_INVOKER})
+ endif()
endif()
# Directoy Monitor
@@ -17,7 +28,18 @@ if (WITH_INV_DIRMON)
file(GLOB_RECURSE DIRMON_INVOKER
dirmon/*.cpp
dirmon/*.h)
+ if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${DIRMON_INVOKER})
+ add_library(invoker_dirmon SHARED ${DIRMON_INVOKER} "../Plugins.cpp")
+ target_link_libraries(invoker_dirmon
+ uscxml
+ )
+ set_target_properties(invoker_dirmon PROPERTIES FOLDER "Plugins//Invoker")
+ set_target_properties(invoker_dirmon PROPERTIES COMPILE_FLAGS "-DPLUMA_EXPORTS")
+ set_target_properties(invoker_dirmon PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_BINARY_DIR}/lib/plugins")
+ else()
list (APPEND USCXML_FILES ${DIRMON_INVOKER})
+ endif()
endif()
set(USCXML_INCLUDE_DIRS ${USCXML_INCLUDE_DIRS} PARENT_SCOPE)