summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/invoker/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-14 16:15:09 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-01-14 16:15:09 (GMT)
commit836927aa902696297febc95132e2c82147c08c03 (patch)
tree64bcbaa67c6f70acdb5f4cc9184f600fad46b826 /src/uscxml/plugins/invoker/CMakeLists.txt
parentf7ca1ebaa5a527f817892bc3794452df1a6c20c6 (diff)
downloaduscxml-836927aa902696297febc95132e2c82147c08c03.zip
uscxml-836927aa902696297febc95132e2c82147c08c03.tar.gz
uscxml-836927aa902696297febc95132e2c82147c08c03.tar.bz2
Expect Invoker and Fedora build fixes
Diffstat (limited to 'src/uscxml/plugins/invoker/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/invoker/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/uscxml/plugins/invoker/CMakeLists.txt b/src/uscxml/plugins/invoker/CMakeLists.txt
index 6dd78ec..607e64e 100644
--- a/src/uscxml/plugins/invoker/CMakeLists.txt
+++ b/src/uscxml/plugins/invoker/CMakeLists.txt
@@ -95,6 +95,26 @@ else()
endif()
+# expect invoker
+
+set(USCXML_INVOKERS "expect ${USCXML_INVOKERS}")
+file(GLOB_RECURSE EXPECT_INVOKER
+ expect/*.cpp
+ expect/*.h
+)
+if (BUILD_AS_PLUGINS)
+ source_group("" FILES EXPECT_INVOKER)
+ add_library(
+ invoker_expect SHARED
+ ${EXPECT_INVOKER}
+ "../Plugins.cpp")
+ target_link_libraries(invoker_expect uscxml)
+ set_target_properties(invoker_expect PROPERTIES FOLDER "Plugin Invoker")
+else()
+ list (APPEND USCXML_FILES ${EXPECT_INVOKER})
+endif()
+
+
# SQLite3 SQL Invoker
if (SQLITE3_FOUND)