summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/ioprocessor/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-11 20:25:39 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-11 20:25:39 (GMT)
commitef551cb937956e2c13570ab3f8f119c48fa5656e (patch)
treefb12268c38f7bbdddd583859d8c615411048d071 /src/uscxml/plugins/ioprocessor/CMakeLists.txt
parent1924f35d1d21a59939110f7eae238052c37474e2 (diff)
downloaduscxml-ef551cb937956e2c13570ab3f8f119c48fa5656e.zip
uscxml-ef551cb937956e2c13570ab3f8f119c48fa5656e.tar.gz
uscxml-ef551cb937956e2c13570ab3f8f119c48fa5656e.tar.bz2
Reactivated plugin system
Diffstat (limited to 'src/uscxml/plugins/ioprocessor/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/ioprocessor/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/src/uscxml/plugins/ioprocessor/CMakeLists.txt b/src/uscxml/plugins/ioprocessor/CMakeLists.txt
index 8f124ed..bcab37c 100644
--- a/src/uscxml/plugins/ioprocessor/CMakeLists.txt
+++ b/src/uscxml/plugins/ioprocessor/CMakeLists.txt
@@ -3,8 +3,8 @@ file(GLOB_RECURSE SAMPLE_IOPROCESSOR
sample/*.cpp
sample/*.h
)
-source_group("IOProcessor\\sample" FILES ${SAMPLE_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${SAMPLE_IOPROCESSOR})
add_library(
ioprocessor_sample SHARED
${SAMPLE_IOPROCESSOR})
@@ -19,8 +19,8 @@ file(GLOB_RECURSE COMET_IOPROCESSOR
comet/*.cpp
comet/*.h
)
-source_group("IOProcessor\\comet" FILES ${COMET_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${COMET_IOPROCESSOR})
add_library(
ioprocessor_comet SHARED
${COMET_IOPROCESSOR})
@@ -38,8 +38,8 @@ file(GLOB_RECURSE BASICHTTP_IOPROCESSOR
basichttp/*.cpp
basichttp/*.h
)
-source_group("IOProcessor\\basichttp" FILES ${BASICHTTP_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${BASICHTTP_IOPROCESSOR})
add_library(
ioprocessor_basichttp SHARED
${BASICHTTP_IOPROCESSOR})
@@ -57,12 +57,13 @@ file(GLOB_RECURSE SCXML_IOPROCESSOR
scxml/*.cpp
scxml/*.h
)
-source_group("IOProcessor\\scxml" FILES ${SCXML_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${SCXML_IOPROCESSOR})
add_library(
ioprocessor_scxml SHARED
${SCXML_IOPROCESSOR})
- target_link_libraries(ioprocessor_scxml uscxml)
+ # scxml ioprocessor is a basichttp ioprocessor
+ target_link_libraries(ioprocessor_scxml ioprocessor_basichttp uscxml)
set_target_properties(ioprocessor_scxml PROPERTIES FOLDER "Plugin IOProcessor")
else()
list (APPEND USCXML_FILES ${SCXML_IOPROCESSOR})
@@ -71,7 +72,7 @@ endif()
# mmi ioprocessor
-if (PROTOBUF_FOUND)
+if (PROTOBUF_FOUND AND OFF)
if (NOT PROTOBUF_PROTOC_EXECUTABLE)
message(FATAL_ERROR "protoc binary required for serialization")
@@ -94,8 +95,8 @@ if (PROTOBUF_FOUND)
add_library(mmi_proto STATIC ${PROTO_SRCS})
set_target_properties(mmi_proto PROPERTIES FOLDER "Generated")
- source_group("IOProcessor\\modality" FILES ${MMI_IOPROCESSOR})
if (BUILD_AS_PLUGINS)
+ source_group("" FILES ${MMI_IOPROCESSOR})
add_library(
ioprocessor_mmi SHARED
${MMI_IOPROCESSOR})