summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-08 00:24:59 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2013-10-08 00:24:59 (GMT)
commit8daf2ea0a7192e556cc059c2220469ea22155380 (patch)
tree20494f647dad5dbea56f9c0a5b7241d1e9e3c7f7 /test/CMakeLists.txt
parent3a8a7a56ab604c3cca49792973c8b0c6d8a089b9 (diff)
downloaduscxml-8daf2ea0a7192e556cc059c2220469ea22155380.zip
uscxml-8daf2ea0a7192e556cc059c2220469ea22155380.tar.gz
uscxml-8daf2ea0a7192e556cc059c2220469ea22155380.tar.bz2
More fixes for MSVC
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 51fe962..4fba8a5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -68,11 +68,12 @@ if (NOT WIN32)
add_test(test-stress ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-stress ${CMAKE_SOURCE_DIR}/test/samples/w3c)
set_target_properties(test-stress PROPERTIES FOLDER "Tests")
- add_executable(test-instant-messaging src/test-instant-messaging.cpp)
- target_link_libraries(test-instant-messaging uscxml)
- add_test(test-instant-messaging ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-instant-messaging)
- set_target_properties(test-instant-messaging PROPERTIES FOLDER "Tests")
-
+ if (LIBPURPLE_FOUND)
+ add_executable(test-instant-messaging src/test-instant-messaging.cpp)
+ target_link_libraries(test-instant-messaging uscxml)
+ add_test(test-instant-messaging ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-instant-messaging)
+ set_target_properties(test-instant-messaging PROPERTIES FOLDER "Tests")
+ endif()
endif()
add_executable(test-url src/test-url.cpp)
@@ -113,7 +114,7 @@ set_target_properties(scxml-test-framework-client PROPERTIES FOLDER "Tests")
# add_test(test-curl-multi-api ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-completion)
# set_target_properties(test-curl-multi-api PROPERTIES FOLDER "Tests")
- add_executable(test-w3c src/test-w3c.cpp ${PROJECT_SOURCE_DIR}/contrib/src/getopt/XGetopt.cpp)
+ add_executable(test-w3c src/test-w3c.cpp)
target_link_libraries(test-w3c uscxml)
set_target_properties(test-w3c PROPERTIES FOLDER "Tests")