summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-05-22 07:40:35 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2014-05-22 07:40:35 (GMT)
commit1e66bfd04f864a040b1e4a68f0db0f55f15b91a3 (patch)
treec254dc899d79e0fc6962ef2d2d5dfc26de1a6766 /test/CMakeLists.txt
parentf9a620340ddce2a17fd775d1e210268cac13377b (diff)
downloaduscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.zip
uscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.tar.gz
uscxml-1e66bfd04f864a040b1e4a68f0db0f55f15b91a3.tar.bz2
Builds with MSVC again
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 49169fc..f28633e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -57,17 +57,17 @@ if (OFF)
set_target_properties(test-dirmon PROPERTIES FOLDER "Tests")
endif()
-add_executable(test-arabica-namespaces src/test-arabica-namespaces.cpp)
-target_link_libraries(test-arabica-namespaces uscxml)
-add_test(test-arabica-namespaces ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-arabica-namespaces ${CMAKE_SOURCE_DIR}/test)
-set_target_properties(test-arabica-namespaces PROPERTIES FOLDER "Tests")
-
add_executable(test-lifecycle src/test-lifecycle.cpp)
target_link_libraries(test-lifecycle uscxml)
add_test(test-lifecycle ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-arabica-namespaces)
set_target_properties(test-lifecycle PROPERTIES FOLDER "Tests")
if (NOT WIN32)
+ add_executable(test-arabica-namespaces src/test-arabica-namespaces.cpp)
+ target_link_libraries(test-arabica-namespaces uscxml)
+ add_test(test-arabica-namespaces ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-arabica-namespaces ${CMAKE_SOURCE_DIR}/test)
+ set_target_properties(test-arabica-namespaces PROPERTIES FOLDER "Tests")
+
add_executable(test-arabica-events src/test-arabica-events.cpp)
target_link_libraries(test-arabica-events uscxml)
add_test(test-arabica-events ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-arabica-events ${CMAKE_SOURCE_DIR}/test/uscxml/arabica/test-arabica-events.xml)