summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-21 18:07:27 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-21 18:07:27 (GMT)
commit93d0fee20cafb44b3de2fb2faa88bc13f739d295 (patch)
tree53aa62bd0437a1d947da9f010f49bc7b9328d24b /test/CMakeLists.txt
parent501e7730acc35934dee481207a7a6c6575b1b342 (diff)
downloaduscxml-93d0fee20cafb44b3de2fb2faa88bc13f739d295.zip
uscxml-93d0fee20cafb44b3de2fb2faa88bc13f739d295.tar.gz
uscxml-93d0fee20cafb44b3de2fb2faa88bc13f739d295.tar.bz2
Fixed tests again
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 7bd6c47..9013dd0 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -1,43 +1,43 @@
add_executable(test-predicates src/test-predicates.cpp)
target_link_libraries(test-predicates uscxml)
-add_test(test-predicates ${CURRENT_BINARY_DIR}/test-predicates ${CMAKE_SOURCE_DIR}/test/src/test-predicates.scxml)
+add_test(test-predicates ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-predicates ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-predicates.scxml)
set_target_properties(test-predicates PROPERTIES FOLDER "Tests")
add_executable(test-execution src/test-execution.cpp)
target_link_libraries(test-execution uscxml)
-add_test(test-execution ${CURRENT_BINARY_DIR}/test-execution ${CMAKE_SOURCE_DIR}/test/src/test-execution.scxml)
+add_test(test-execution ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-execution ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-execution.scxml)
set_target_properties(test-execution PROPERTIES FOLDER "Tests")
add_executable(test-apache-commons src/test-apache-commons.cpp)
target_link_libraries(test-apache-commons uscxml)
-add_test(test-apache-commons ${CURRENT_BINARY_DIR}/test-apache-commons ${CMAKE_SOURCE_DIR}/test/samples/apache)
+add_test(test-apache-commons ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-apache-commons ${CMAKE_SOURCE_DIR}/test/samples/apache)
set_target_properties(test-apache-commons PROPERTIES FOLDER "Tests")
if (V8_FOUND)
add_executable(test-ecmascript-v8 src/test-ecmascript-v8.cpp)
target_link_libraries(test-ecmascript-v8 uscxml)
- add_test(test-ecmascript-v8 ${CURRENT_BINARY_DIR}/test-ecmascript-v8 ${CMAKE_SOURCE_DIR}/test/src/test-ecmascript.scxml)
+ add_test(test-ecmascript-v8 ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-ecmascript-v8 ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-ecmascript.scxml)
set_target_properties(test-ecmascript-v8 PROPERTIES FOLDER "Tests")
endif()
if (SWI_FOUND)
add_executable(test-prolog-swi src/test-prolog-swi.cpp)
target_link_libraries(test-prolog-swi uscxml)
- add_test(test-prolog-swi ${CURRENT_BINARY_DIR}/test-prolog-swi ${CMAKE_SOURCE_DIR}/test/src/test-prolog.scxml)
+ add_test(test-prolog-swi ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-prolog-swi ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-prolog.scxml)
set_target_properties(test-prolog-swi PROPERTIES FOLDER "Tests")
endif()
add_executable(test-communication src/test-communication.cpp)
target_link_libraries(test-communication uscxml)
-add_test(test-communication ${CURRENT_BINARY_DIR}/test-communication ${CMAKE_SOURCE_DIR}/test/src/test-communication.scxml)
+add_test(test-communication ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-communication ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-communication.scxml)
set_target_properties(test-communication PROPERTIES FOLDER "Tests")
add_executable(test-eventdelay src/test-eventdelay.cpp)
target_link_libraries(test-eventdelay uscxml)
-add_test(test-eventdelay ${CURRENT_BINARY_DIR}/test-eventdelay)
+add_test(test-eventdelay ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-eventdelay)
set_target_properties(test-eventdelay PROPERTIES FOLDER "Tests")
add_executable(test-completion src/test-completion.cpp)
target_link_libraries(test-completion uscxml)
-add_test(test-completion ${CURRENT_BINARY_DIR}/test-completion ${CMAKE_SOURCE_DIR}/test/src/test-donedata.scxml)
+add_test(test-completion ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/test-completion ${CMAKE_SOURCE_DIR}/test/samples/uscxml/test-donedata.scxml)
set_target_properties(test-completion PROPERTIES FOLDER "Tests")