summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-20 21:34:09 (GMT)
committerStefan Radomski <radomski@tk.informatik.tu-darmstadt.de>2012-12-20 21:34:09 (GMT)
commit498f6f80e9ca01236ca1491596875ab7eb4cd8c3 (patch)
treee627ae19475bb93a98dfa50db1950f6e3403f569 /test/CMakeLists.txt
parentd779abe6ff76a78f92d229fcf1f006f5cf1f9295 (diff)
downloaduscxml-498f6f80e9ca01236ca1491596875ab7eb4cd8c3.zip
uscxml-498f6f80e9ca01236ca1491596875ab7eb4cd8c3.tar.gz
uscxml-498f6f80e9ca01236ca1491596875ab7eb4cd8c3.tar.bz2
Refactoring finished
Support datamodels, invokers and ioprocessors as plugins Comply to HTTP1.1 by sending host header field Started prolog datamodel
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1fdaaee..7bd6c47 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -13,10 +13,19 @@ target_link_libraries(test-apache-commons uscxml)
add_test(test-apache-commons ${CURRENT_BINARY_DIR}/test-apache-commons ${CMAKE_SOURCE_DIR}/test/samples/apache)
set_target_properties(test-apache-commons PROPERTIES FOLDER "Tests")
-add_executable(test-ecmascript-v8 src/test-ecmascript-v8.cpp)
-target_link_libraries(test-ecmascript-v8 uscxml)
-add_test(test-ecmascript-v8 ${CURRENT_BINARY_DIR}/test-ecmascript-v8 ${CMAKE_SOURCE_DIR}/test/src/test-ecmascript.scxml)
-set_target_properties(test-ecmascript-v8 PROPERTIES FOLDER "Tests")
+if (V8_FOUND)
+ add_executable(test-ecmascript-v8 src/test-ecmascript-v8.cpp)
+ target_link_libraries(test-ecmascript-v8 uscxml)
+ add_test(test-ecmascript-v8 ${CURRENT_BINARY_DIR}/test-ecmascript-v8 ${CMAKE_SOURCE_DIR}/test/src/test-ecmascript.scxml)
+ set_target_properties(test-ecmascript-v8 PROPERTIES FOLDER "Tests")
+endif()
+
+if (SWI_FOUND)
+ add_executable(test-prolog-swi src/test-prolog-swi.cpp)
+ target_link_libraries(test-prolog-swi uscxml)
+ add_test(test-prolog-swi ${CURRENT_BINARY_DIR}/test-prolog-swi ${CMAKE_SOURCE_DIR}/test/src/test-prolog.scxml)
+ set_target_properties(test-prolog-swi PROPERTIES FOLDER "Tests")
+endif()
add_executable(test-communication src/test-communication.cpp)
target_link_libraries(test-communication uscxml)