summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6ce335..31fb7c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -520,8 +520,9 @@ endif()
# OpenSceneGraph invoker
-find_package(OpenSceneGraph)
+find_package(OpenSceneGraph COMPONENTS osgDB osgGA osgUtil osgText osgFX osgManipulator osgViewer OpenThreads)
if (OPENSCENEGRAPH_FOUND)
+ include_directories(${OPENSCENEGRAPH_INCLUDE_DIRS})
file(GLOB_RECURSE OPENSCENEGRAPH_INVOKER
src/uscxml/plugins/invoker/graphics/openscenegraph/*.cpp
src/uscxml/plugins/invoker/graphics/openscenegraph/*.h)