summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87fc2e5..6bcf0a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,6 +122,8 @@ endif()
if(${CMAKE_CXX_COMPILER_ID} STREQUAL GNU)
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL Clang)
+ # see http://askubuntu.com/questions/523613/upgrade-to-gcc-4-9-broke-clang
+ add_definitions("-stdlib=libc++")
elseif (${CMAKE_CXX_COMPILER_ID} STREQUAL MSVC)
add_definitions("-D_SCL_SECURE_NO_WARNINGS")