summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt34
1 files changed, 17 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a5bbbd..c591ab5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,7 +97,7 @@ include_directories(contrib/src)
include_directories(${CMAKE_BINARY_DIR})
include_directories(${PROJECT_SOURCE_DIR}/contrib/src/jsmn)
include_directories(${PROJECT_SOURCE_DIR}/contrib/src/evws)
-# include_directories(${PROJECT_SOURCE_DIR}/contrib/src/uriparser/include)
+include_directories(${PROJECT_SOURCE_DIR}/contrib/src/uriparser/include)
set(GETOPT_FILES ${PROJECT_SOURCE_DIR}/contrib/src/uscxml/InterpreterOptions.cpp)
if (WIN32)
@@ -306,22 +306,22 @@ endif()
# uriparser
-find_package(uriparser)
-if(URIPARSER_FOUND)
- include_directories(${URIPARSER_INCLUDE_DIRS})
- list (APPEND USCXML_CORE_LIBS ${URIPARSER_LIBRARIES})
-else()
- message(STATUS "Did not find UriParser")
- message(STATUS "--> will download and compile")
- include("${CMAKE_MODULE_PATH}/BuildURIParser.cmake")
- if (URIPARSER_BUILT)
- include_directories(${URIPARSER_INCLUDE_DIR})
- list (APPEND USCXML_CORE_LIBS ${URIPARSER_LIBRARY})
- list (APPEND USCXML_PREREQS uriparser)
- else()
- message(FATAL_ERROR "Could not find or build uriparser")
- endif()
-endif()
+# find_package(uriparser)
+# if(URIPARSER_FOUND)
+# include_directories(${URIPARSER_INCLUDE_DIRS})
+# list (APPEND USCXML_CORE_LIBS ${URIPARSER_LIBRARIES})
+# else()
+# message(STATUS "Did not find UriParser")
+# message(STATUS "--> will download and compile")
+# include("${CMAKE_MODULE_PATH}/BuildURIParser.cmake")
+# if (URIPARSER_BUILT)
+# include_directories(${URIPARSER_INCLUDE_DIR})
+# list (APPEND USCXML_CORE_LIBS ${URIPARSER_LIBRARY})
+# list (APPEND USCXML_PREREQS uriparser)
+# else()
+# message(FATAL_ERROR "Could not find or build uriparser")
+# endif()
+# endif()
################################