summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f1fecb..4c2e3dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -474,6 +474,20 @@ endif()
add_subdirectory(src/uscxml)
add_subdirectory(src/bindings)
+# https://gcc.gnu.org/onlinedocs/gcc-4.7.2/gcc/Optimize-Options.html#Optimize-Options
+# https://clang.llvm.org/docs/UsersManual.html#profile-guided-optimization
+if (${CMAKE_CXX_COMPILER_ID} STREQUAL Clang)
+ # add_definitions("-fprofile-instr-generate")
+ # add_definitions("-fprofile-generate=profiling")
+ # no measureable effect
+ # set_property(SOURCE src/uscxml/interpreter/FastMicroStep.cpp APPEND_STRING PROPERTY COMPILE_FLAGS " -fprofile-instr-generate=foo")
+ # set_property(SOURCE src/uscxml/interpreter/FastMicroStep.cpp APPEND_STRING PROPERTY COMPILE_FLAGS " -Ofast")
+ # set_property(SOURCE src/uscxml/interpreter/LargeMicroStep.cpp APPEND_STRING PROPERTY COMPILE_FLAGS " -Ofast")
+ # set_property(SOURCE src/uscxml/interpreter/FastMicroStep.cpp APPEND_STRING PROPERTY COMPILE_FLAGS " -fomit-frame-pointer")
+ # set_property(SOURCE src/uscxml/interpreter/LargeMicroStep.cpp APPEND_STRING PROPERTY COMPILE_FLAGS " -fomit-frame-pointer")
+endif()
+
+
if (BUILD_AS_PLUGINS)
file(GLOB USCXML_PLUGINS
${CMAKE_SOURCE_DIR}/contrib/src/Pluma/*.cpp
@@ -513,13 +527,13 @@ if (NOT CMAKE_CROSSCOMPILING)
add_subdirectory(test)
endif()
-add_executable(uscxml-browser apps/uscxml-browser.cpp ${GETOPT_FILES})
+add_executable(uscxml-browser src/apps/uscxml-browser.cpp ${GETOPT_FILES})
set_property(TARGET uscxml-browser PROPERTY CXX_STANDARD 11)
set_property(TARGET uscxml-browser PROPERTY CXX_STANDARD_REQUIRED ON)
install_executable(TARGETS uscxml-browser COMPONENT tools)
target_link_libraries(uscxml-browser uscxml)
-add_executable(uscxml-transform apps/uscxml-transform.cpp ${GETOPT_FILES})
+add_executable(uscxml-transform src/apps/uscxml-transform.cpp ${GETOPT_FILES})
set_property(TARGET uscxml-transform PROPERTY CXX_STANDARD 11)
set_property(TARGET uscxml-transform PROPERTY CXX_STANDARD_REQUIRED ON)
install_executable(TARGETS uscxml-transform COMPONENT tools)