summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8a3545..2cd37de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -253,8 +253,10 @@ else()
endif()
endif()
+
#OpenSSL
find_package(OpenSSL)
+# https://slproweb.com/products/Win32OpenSSL.html
if (OPENSSL_FOUND)
include_directories(${OPENSSL_INCLUDE_DIR})
list (APPEND USCXML_CORE_LIBS ${OPENSSL_LIBRARIES})
@@ -331,6 +333,7 @@ if (";${LIBEVENT_LIBRARIES};" MATCHES "openssl")
set(EVENT_SSL_FOUND ON)
endif()
+
if (UNIX)
list (APPEND USCXML_CORE_LIBS "pthread")
endif()
@@ -413,10 +416,13 @@ OPTION(WITH_DM_LUA "Do search for the Lua libraries" ON)
if (WITH_DM_LUA)
if (WIN32)
# LuaForWindows https://code.google.com/archive/p/luaforwindows/downloads
- set(ENV{LUA_DIR} "C:/Program Files (x86)/Lua/5.1/")
+ # set(ENV{LUA_DIR} "C:/Program Files (x86)/Lua/5.1/")
+
+ # http://luabinaries.sourceforge.net/download.html
+ set(ENV{LUA_DIR} "C:/Program Files (x86)/Lua/5.3/")
endif()
- find_package(Lua51)
- if (LUA51_FOUND)
+ find_package(Lua)
+ if (LUA_FOUND)
include_directories (${LUA_INCLUDE_DIR})
include_directories(${PROJECT_SOURCE_DIR}/contrib/src/LuaBridge)
list (APPEND USCXML_OPT_LIBS ${LUA_LIBRARIES})