summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 16 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 533106e..4e7cadc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -402,6 +402,12 @@ endforeach()
OPTION(BUILD_AS_PLUGINS "Build invokers, ioprocessors and datamodels as plugins" OFF)
+if (BUILD_AS_PLUGINS)
+ add_definitions("-DBUILD_AS_PLUGINS")
+ include_directories("src/uscxml/plugins")
+# list(APPEND USCXML_FILES "src/uscxml/plugins/Plugins.cpp")
+endif()
+
# this is where the config.h ends up
include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(src)
@@ -444,8 +450,10 @@ if (NOT WIN32)
elseif(APPLE)
find_library(APP_SERVICES_LIBRARY ApplicationServices)
find_library(COREFOUNDATION_LIBRARY CoreFoundation)
+ find_library(FOUNDATION_LIBRARY Foundation)
list (APPEND USCXML_CORE_LIBS ${APP_SERVICES_LIBRARY})
list (APPEND USCXML_CORE_LIBS ${COREFOUNDATION_LIBRARY})
+ list (APPEND USCXML_CORE_LIBS ${FOUNDATION_LIBRARY})
endif()
elseif(WIN32)
list (APPEND XML_LIBRARIES "Ws2_32")
@@ -653,11 +661,11 @@ endif()
find_package(MILES)
if (MILES_FOUND)
# openal is only needed for miles
- # find_package(OpenAL REQUIRED)
- # find_package(JPEG REQUIRED)
- # list (APPEND MILES_LIBRARIES "iconv")
- # list (APPEND MILES_LIBRARIES ${JPEG_LIBRARIES})
- # list (APPEND USCXML_INCLUDE_DIRS ${OPENAL_INCLUDE_DIR})
+ find_package(OpenAL REQUIRED)
+ find_package(JPEG REQUIRED)
+ list (APPEND MILES_LIBRARIES "iconv")
+ list (APPEND MILES_LIBRARIES ${JPEG_LIBRARIES})
+ list (APPEND USCXML_INCLUDE_DIRS ${OPENAL_INCLUDE_DIR})
include_directories (${MILES_INCLUDE_DIR})
list (APPEND USCXML_OPT_LIBS ${MILES_LIBRARIES})
@@ -757,7 +765,7 @@ endif()
if (NOT CMAKE_CROSSCOMPILING)
set_target_properties(uscxml PROPERTIES COTIRE_CXX_PREFIX_HEADER_INIT "src/uscxml/pch.h")
set_target_properties(uscxml PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
- cotire(uscxml)
+# cotire(uscxml)
endif()
if (NOT CMAKE_CROSSCOMPILING)
@@ -765,13 +773,13 @@ if (NOT CMAKE_CROSSCOMPILING)
target_link_libraries(uscxml-browser uscxml)
if (NOT CMAKE_CROSSCOMPILING)
set_target_properties(uscxml-browser PROPERTIES COTIRE_ADD_UNITY_BUILD FALSE)
- cotire(uscxml-browser)
+# cotire(uscxml-browser)
endif()
set_target_properties(uscxml-browser PROPERTIES FOLDER "Apps")
install_executable(TARGETS uscxml-browser COMPONENT tools)
- if (PROTOBUF_FOUND)
+ if (PROTOBUF_FOUND AND OFF)
file(GLOB W3C-MMI-COMMON ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/*.h)
file(GLOB_RECURSE W3C-MMI-IM ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.cpp ${PROJECT_SOURCE_DIR}/apps/w3c-mmi/im/*.h)