summaryrefslogtreecommitdiffstats
path: root/src/uscxml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/uscxml/CMakeLists.txt')
-rw-r--r--src/uscxml/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/uscxml/CMakeLists.txt b/src/uscxml/CMakeLists.txt
index da620fb..c38bcbf 100644
--- a/src/uscxml/CMakeLists.txt
+++ b/src/uscxml/CMakeLists.txt
@@ -25,6 +25,13 @@ file(GLOB_RECURSE USCXML_CONCURRENCY
source_group("Interpreter" FILES ${USCXML_CONCURRENCY})
list (APPEND USCXML_FILES ${USCXML_CONCURRENCY})
+file(GLOB_RECURSE USCXML_MESSAGES
+ messages/*.cpp
+ messages/*.h
+)
+source_group("Interpreter" FILES ${USCXML_MESSAGES})
+list (APPEND USCXML_FILES ${USCXML_MESSAGES})
+
file(GLOB_RECURSE USCXML_DEBUG
debug/*.cpp
debug/*.h
@@ -63,6 +70,16 @@ file(GLOB USCXML_CORE
source_group("Interpreter" FILES ${USCXML_CORE})
list (APPEND USCXML_FILES ${USCXML_CORE})
+file(GLOB USCXML_PLUGINS
+ plugins/DataModel.h
+ plugins/EventHandler.h
+ plugins/ExecutableContent.h
+ plugins/Invoker.h
+ plugins/IOProcessor.h
+)
+source_group("Interpreter" FILES ${USCXML_PLUGINS})
+list (APPEND USCXML_FILES ${USCXML_PLUGINS})
+
if (BUILD_AS_PLUGINS)
list (APPEND USCXML_INCLUDE_DIRS ${PROJECT_SOURCE_DIR}/plugins)
file(GLOB PLUMA