summaryrefslogtreecommitdiffstats
path: root/src/uscxml/plugins/invoker/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/uscxml/plugins/invoker/CMakeLists.txt')
-rw-r--r--src/uscxml/plugins/invoker/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/uscxml/plugins/invoker/CMakeLists.txt b/src/uscxml/plugins/invoker/CMakeLists.txt
index 3f43acb..4e74a8c 100644
--- a/src/uscxml/plugins/invoker/CMakeLists.txt
+++ b/src/uscxml/plugins/invoker/CMakeLists.txt
@@ -32,6 +32,23 @@ else()
list (APPEND USCXML_FILES ${DIRMON_INVOKER})
endif()
+# System invoker to open a native command
+
+file(GLOB_RECURSE XHTML_INVOKER
+ xhtml/*.cpp
+ xhtml/*.h
+)
+source_group("Invoker\\xhtml" FILES ${XHTML_INVOKER})
+if (BUILD_AS_PLUGINS)
+ add_library(
+ invoker_xhtml SHARED
+ ${XHTML_INVOKER})
+ target_link_libraries(invoker_xhtml uscxml)
+ set_target_properties(invoker_xhtml PROPERTIES FOLDER "Plugin Invoker")
+else()
+ list (APPEND USCXML_FILES ${XHTML_INVOKER})
+endif()
+
# System invoker to open a native command