summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-11-12 19:24:51 (GMT)
committerBrad King <brad.king@kitware.com>2013-11-12 20:47:06 (GMT)
commit06b0dbe0614c08a8ec80ce69e7679b0faa7e69dc (patch)
tree6ecbf998bb347d49f11161a8d85b33bf6e4fae99 /CMakeLists.txt
parent84af42b989fe919fee65fa0809d053a347d3f000 (diff)
downloadCMake-06b0dbe0614c08a8ec80ce69e7679b0faa7e69dc.zip
CMake-06b0dbe0614c08a8ec80ce69e7679b0faa7e69dc.tar.gz
CMake-06b0dbe0614c08a8ec80ce69e7679b0faa7e69dc.tar.bz2
OS X: Drop version number from CMake.app bundle name (#11693)
Always name the application bundle "CMake.app". Users can rename it after installation if they wish. This is the typical approach used by OS X applications, including Xcode. It allows CMake to be upgraded without manually re-running CMake in every build tree to update the path to CMake. It also makes the executable location in the CMake build tree more predicatable.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 25cd576..d6237b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -484,7 +484,6 @@ if(BUILD_QtDialog)
if(APPLE)
set(CMAKE_BUNDLE_VERSION
"${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}.${CMake_VERSION_PATCH}")
- set(CMAKE_BUNDLE_NAME "CMake ${CMAKE_BUNDLE_VERSION}")
set(CMAKE_BUNDLE_LOCATION "${CMAKE_INSTALL_PREFIX}")
# make sure CMAKE_INSTALL_PREFIX ends in /
string(LENGTH "${CMAKE_INSTALL_PREFIX}" LEN)
@@ -494,7 +493,7 @@ if(BUILD_QtDialog)
set(CMAKE_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/")
endif()
set(CMAKE_INSTALL_PREFIX
- "${CMAKE_INSTALL_PREFIX}${CMAKE_BUNDLE_NAME}.app/Contents")
+ "${CMAKE_INSTALL_PREFIX}CMake.app/Contents")
endif()
set(QT_NEED_RPATH FALSE)