summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-02-28 22:12:14 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-02-28 22:12:14 (GMT)
commit172e8972608966f10aa43ae6d5afef2e1d42a6f6 (patch)
tree63da0142e3b863b71a5bc0ffac30d96202ecd064 /CMakeLists.txt
parent638eb8e68eb22c4dd048d5a225dffb376b701691 (diff)
downloadCMake-172e8972608966f10aa43ae6d5afef2e1d42a6f6.zip
CMake-172e8972608966f10aa43ae6d5afef2e1d42a6f6.tar.gz
CMake-172e8972608966f10aa43ae6d5afef2e1d42a6f6.tar.bz2
ENH: Add the rest of xmlrpc stuff
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fdfa54..c0e7bd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,7 +67,14 @@ SUBDIRS(Source/CTest/Curl)
#-----------------------------------------------------------------------------
# Build expat library for CMake and CTest.
INCLUDE_DIRECTORIES(${CMake_BINARY_DIR}/Utilities)
+SET(CMAKE_EXPAT_INCLUDES "${CMAKE_CURRENT_BINARY_DIR}/Utilities/cmexpat")
+SET(CMAKE_EXPAT_LIBRARIES "cmexpat")
+SET(CMAKE_CURL_INCLUDES "${CMAKE_CURRENT_SOURCE_DIR}/Source/CTest/Curl")
+SET(CMAKE_CURL_LIBRARIES "Curl")
SUBDIRS(Utilities/cmexpat Utilities/cmzlib)
+IF(CMAKE_USE_XMLRPC)
+ SUBDIRS(Utilities/cmxmlrpc)
+ENDIF(CMAKE_USE_XMLRPC)
IF (UNIX)
INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)