summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-13 15:45:04 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-15 16:37:17 (GMT)
commit1fc556536e0c0475d401e8b5747b46e9f7c32287 (patch)
treee75032b9fcf4d3792a0293bec94717fa5f3c60c7 /CMakeLists.txt
parent84d5674d4e0cfe30f28db2893ad00937deece57c (diff)
downloadCMake-1fc556536e0c0475d401e8b5747b46e9f7c32287.zip
CMake-1fc556536e0c0475d401e8b5747b46e9f7c32287.tar.gz
CMake-1fc556536e0c0475d401e8b5747b46e9f7c32287.tar.bz2
jsoncpp: Build the library within CMake
Update json/json.h to account for our lack of autolink.h. Update json/config.h to include KWSys Large File Support configuration so that consistent stream libraries are used (on AIX with XL). Add a cm_jsoncpp_reader.h header to include the CMake-provided copy of the json/reader.h header from CMake sources.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1812b27..1847600 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -372,6 +372,11 @@ macro (CMAKE_BUILD_UTILITIES)
endif()
#---------------------------------------------------------------------
+ # Build jsoncpp library.
+ add_subdirectory(Utilities/cmjsoncpp)
+ CMAKE_SET_TARGET_FOLDER(cmjsoncpp "Utilities/3rdParty")
+
+ #---------------------------------------------------------------------
# Build XMLRPC library for CMake and CTest.
if(CTEST_USE_XMLRPC)
find_package(XMLRPC QUIET REQUIRED libwww-client)