summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-05-07 19:02:20 (GMT)
committerBrad King <brad.king@kitware.com>2019-05-08 17:18:31 (GMT)
commit29f4f70b41858b8d89a4cf77a8f87ceb1df3b80a (patch)
tree60094db8dd9abbc2d883ecfc11d768f6e0f07df5 /CMakeLists.txt
parent1069a3f02bbe12fdf326cf7cfdb12820cee6030a (diff)
downloadCMake-29f4f70b41858b8d89a4cf77a8f87ceb1df3b80a.zip
CMake-29f4f70b41858b8d89a4cf77a8f87ceb1df3b80a.tar.gz
CMake-29f4f70b41858b8d89a4cf77a8f87ceb1df3b80a.tar.bz2
Add undocumented option to sign CMake's own binaries on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9274a8a..51a1d8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -822,4 +822,10 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
# Install auxiliary files integrating with other tools.
add_subdirectory(Auxiliary)
+
+ # Optionally sign installed binaries.
+ if(CMake_INSTALL_SIGNTOOL)
+ configure_file(Source/CMakeInstallSignTool.cmake.in Source/CMakeInstallSignTool.cmake @ONLY)
+ install(SCRIPT ${CMAKE_CURRENT_BINARY_DIR}/Source/CMakeInstallSignTool.cmake)
+ endif()
endif()