summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-09-17 19:55:17 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-09-17 19:55:17 (GMT)
commit4ee1ee1bd0d6b19feb5846bfeccdc39a90d52ac8 (patch)
tree911ac1b075af9be769d8999e61dec635b1257f4c /CMakeLists.txt
parentf9391ab2916755b319dff4dd11282425b2c076cc (diff)
downloadCMake-4ee1ee1bd0d6b19feb5846bfeccdc39a90d52ac8.zip
CMake-4ee1ee1bd0d6b19feb5846bfeccdc39a90d52ac8.tar.gz
CMake-4ee1ee1bd0d6b19feb5846bfeccdc39a90d52ac8.tar.bz2
ENH: add support for the Portland Compiler to CMake, can build cmake and the tests pass (except the wrapping tests, which fail to link to the g++-compiled Qt)
Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9aec580..43d6e77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -406,9 +406,9 @@ CMAKE_BUILD_UTILITIES()
IF(BUILD_CursesDialog)
GET_FILENAME_COMPONENT(_CURSES_DIR "${CURSES_LIBRARY}" PATH)
SET(CURSES_NEED_RPATH FALSE)
- IF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib")
+ IF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/lib64" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib64")
SET(CURSES_NEED_RPATH TRUE)
- ENDIF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib")
+ ENDIF(NOT "${_CURSES_DIR}" STREQUAL "/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib" AND NOT "${_CURSES_DIR}" STREQUAL "/lib64" AND NOT "${_CURSES_DIR}" STREQUAL "/usr/lib64")
ENDIF(BUILD_CursesDialog)
# The same might be true on other systems for other libraries if