summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-09-29 17:40:21 (GMT)
committerBrad King <brad.king@kitware.com>2016-09-29 17:40:21 (GMT)
commit523f8ec82c5fb62f5f67c962ff59886396abd8fd (patch)
tree49bd04f23f0a4a54030dfdcc8e2525a8d4edb3bf /CMakeLists.txt
parent6b97a5efc6c41a440ed5d9eb5ba9aed834d0bd40 (diff)
downloadCMake-523f8ec82c5fb62f5f67c962ff59886396abd8fd.zip
CMake-523f8ec82c5fb62f5f67c962ff59886396abd8fd.tar.gz
CMake-523f8ec82c5fb62f5f67c962ff59886396abd8fd.tar.bz2
server-mode: Add option to enable/disable test case explicitly
Add a `CMake_TEST_SERVER_MODE` option that can be set in testing builds to enable/disable server mode tests explicitly. This will allow testing in combination with `CMake_TEST_EXTERNAL_CMAKE` or for server mode to be built on systems that have a python version that cannot run the test.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f39ddf3..309e224 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -715,6 +715,9 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
else()
set(CMake_ENABLE_SERVER_MODE 0)
endif()
+if(NOT DEFINED CMake_TEST_SERVER_MODE)
+ set(CMake_TEST_SERVER_MODE ${CMake_ENABLE_SERVER_MODE})
+endif()
if(NOT CMake_TEST_EXTERNAL_CMAKE)
if(NOT CMake_VERSION_IS_RELEASE)