summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2003-02-06 22:48:50 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2003-02-06 22:48:50 (GMT)
commit67ec52b343f4a320080bcd21c2f5736157053815 (patch)
tree41fcd88b6c2490f48295b0774b84624a76cb7203 /CMakeLists.txt
parent61da8f64bf1db35d49325dba2067187a92e9b7ce (diff)
downloadCMake-67ec52b343f4a320080bcd21c2f5736157053815.zip
CMake-67ec52b343f4a320080bcd21c2f5736157053815.tar.gz
CMake-67ec52b343f4a320080bcd21c2f5736157053815.tar.bz2
tell the aix linker not to give warnings with -bhalt:5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5b58e4..4f492ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,13 @@ IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
INCLUDE (${CMAKE_ROOT}/Modules/CMakeBackwardCompatibilityCXX.cmake)
ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
+#silence duplicate symbol warnings on AIX
+IF(CMAKE_SYSTEM MATCHES "AIX.*")
+ IF(NOT CMAKE_COMPILER_IS_GNUCXX)
+ SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -bhalt:5 ")
+ ENDIF(NOT CMAKE_COMPILER_IS_GNUCXX)
+ENDIF(CMAKE_SYSTEM MATCHES "AIX.*")
+
IF(CMAKE_SYSTEM MATCHES "OSF1-V.*")
IF(NOT CMAKE_COMPILER_IS_GNUCXX)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -timplicit_local -no_implicit_include ")