summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-26 13:02:46 (GMT)
committerBrad King <brad.king@kitware.com>2016-08-31 13:09:23 (GMT)
commit7cf369fe276e011d4c9322153ae7c77d5124ca7e (patch)
tree685629adb90f5c26973b46f1db39ac93a11138d1 /CMakeLists.txt
parent075cae5147bdca011841a9ebaf166636ab3e410f (diff)
downloadCMake-7cf369fe276e011d4c9322153ae7c77d5124ca7e.zip
CMake-7cf369fe276e011d4c9322153ae7c77d5124ca7e.tar.gz
CMake-7cf369fe276e011d4c9322153ae7c77d5124ca7e.tar.bz2
Do not build libuv on HP-UX
Some work may be needed to port to HP-UX.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65876d5..4ef2ca2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -484,6 +484,9 @@ int main(void) { return 0; }
elseif(CYGWIN)
# libuv does not support Cygwin
set(CMAKE_USE_LIBUV 0)
+ elseif(CMAKE_SYSTEM_NAME STREQUAL "HP-UX")
+ # Disable until it can be ported.
+ set(CMAKE_USE_LIBUV 0)
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "sparc")
# Disable until it can be ported.
set(CMAKE_USE_LIBUV 0)