summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2003-08-07 20:25:49 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2003-08-07 20:25:49 (GMT)
commit81b5c3b34d9420c91c2269e33bb991e705cd8d4e (patch)
treeab191ab400adb78b955d2abc9df66cbaa7da191f /CMakeLists.txt
parent1de2bba717076e9a74466edabc0eac3aeb8a185d (diff)
downloadCMake-81b5c3b34d9420c91c2269e33bb991e705cd8d4e.zip
CMake-81b5c3b34d9420c91c2269e33bb991e705cd8d4e.tar.gz
CMake-81b5c3b34d9420c91c2269e33bb991e705cd8d4e.tar.bz2
ENH: Fix dependencies for curses dialog
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54fb7f1..013711a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,6 +60,13 @@ SUBDIRS(Source/kwsys)
SET(CMAKE_BUILD_WITH_CURL 1)
SUBDIRS(Source/CTest/Curl)
+IF (UNIX)
+ INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
+ IF (CURSES_LIBRARY)
+ SUBDIRS(Source/CursesDialog/form)
+ ENDIF (CURSES_LIBRARY)
+ENDIF (UNIX)
+
SUBDIRS(Source Modules Templates Utilities)
ENABLE_TESTING()