summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2007-11-06 19:14:18 (GMT)
committerKen Martin <ken.martin@kitware.com>2007-11-06 19:14:18 (GMT)
commit8eae7fddf29dc9531c2c7ac87dcf2dbf4a4c8dec (patch)
tree026ee893e99d624639ff32be8c86689bf9669594 /CMakeLists.txt
parent16ac724c9189af13ea4a4b04584a4498fe907518 (diff)
downloadCMake-8eae7fddf29dc9531c2c7ac87dcf2dbf4a4c8dec.zip
CMake-8eae7fddf29dc9531c2c7ac87dcf2dbf4a4c8dec.tar.gz
CMake-8eae7fddf29dc9531c2c7ac87dcf2dbf4a4c8dec.tar.bz2
ENH: move CMAKE_STRICT option to the top
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 94c3c30..6597c0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -457,6 +457,11 @@ CONFIGURE_FILE(
"${CMAKE_CURRENT_BINARY_DIR}/DartLocal.conf"
COPYONLY)
+OPTION(CMAKE_STRICT
+ "Perform strict testing to record property and variable access. Can be used to report any undefined properties or variables" OFF)
+MARK_AS_ADVANCED(CMAKE_STRICT)
+
+
# build the remaining subdirectories
SUBDIRS(Source)
SUBDIRS(Modules)