summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2014-03-14 14:47:37 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2014-03-14 14:48:18 (GMT)
commit91fd99b86532dbf35d8c7396654b9beac058c8f3 (patch)
tree5a1df0250f91360185f5087386a0906e6aa5debb /CMakeLists.txt
parent82a7d54cfe75c399b66c888acfcb5ddb15af547b (diff)
downloadCMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.zip
CMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.tar.gz
CMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.tar.bz2
Encoding: Provide option to configure CMake to use UTF-8 encoding.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f83015..b0793d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,6 +36,13 @@ if("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
endmacro()
endif()
+# option to set the internal encoding of CMake to UTF-8
+option(CMAKE_ENCODING_UTF8 "Use UTF-8 encoding internally (experimental)." OFF)
+mark_as_advanced(CMAKE_ENCODING_UTF8)
+if(CMAKE_ENCODING_UTF8)
+ set(KWSYS_ENCODING_DEFAULT_CODEPAGE CP_UTF8)
+endif()
+
#-----------------------------------------------------------------------
# a macro to deal with system libraries, implemented as a macro
# simply to improve readability of the main script