summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-06-27 18:15:37 (GMT)
committerBrad King <brad.king@kitware.com>2011-06-27 18:15:37 (GMT)
commit93cebcaf23118425c1ac51fcd07073c376be4e34 (patch)
treeca69dc75beffd6eca64adfa7a93c022648f36373 /CMakeLists.txt
parentb2975adb31b891d87bb9828097a10167b811e96b (diff)
downloadCMake-93cebcaf23118425c1ac51fcd07073c376be4e34.zip
CMake-93cebcaf23118425c1ac51fcd07073c376be4e34.tar.gz
CMake-93cebcaf23118425c1ac51fcd07073c376be4e34.tar.bz2
Configure KWIML inside CMake as cmIML
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 93822ef..09fd7d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,6 +214,12 @@ ENDMACRO(CMAKE_SET_TARGET_FOLDER)
#-----------------------------------------------------------------------
MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
+ # Create the KWIML library for CMake.
+ SET(KWIML cmIML)
+ SET(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
+ ADD_SUBDIRECTORY(Utilities/KWIML)
+
+ #---------------------------------------------------------------------
# Create the kwsys library for CMake.
SET(KWSYS_NAMESPACE cmsys)
SET(KWSYS_USE_SystemTools 1)