summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-01-09 18:15:19 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-01-09 18:15:19 (GMT)
commitaa9734ab6ceab283c83615ea52644ff730651dbc (patch)
tree7777e4ae53728b1de1a6035c071aa9f35ee3a1ff /CMakeLists.txt
parent6d113b9a8521b15dfff6e38229f292b9ffb64d10 (diff)
downloadCMake-aa9734ab6ceab283c83615ea52644ff730651dbc.zip
CMake-aa9734ab6ceab283c83615ea52644ff730651dbc.tar.gz
CMake-aa9734ab6ceab283c83615ea52644ff730651dbc.tar.bz2
STYLE: Add an explanation for a bunch of backslashes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8600c55..8fe86bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -188,6 +188,8 @@ IF(EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
SET(CPACK_PACKAGE_VERSION_MINOR "${CMake_VERSION_MINOR}")
SET(CPACK_PACKAGE_VERSION_PATCH "${CMake_VERSION_PATCH}")
IF(WIN32 AND NOT UNIX)
+ # There is a bug in NSI that does not handle full unix paths properly. Make
+ # sure there is at least one set of four (4) backlasshes.
SET(CPACK_PACKAGE_ICON "${CMake_SOURCE_DIR}/Utilities/Release\\\\CMakeInstall.bmp")
ENDIF(WIN32 AND NOT UNIX)
INCLUDE(CPack)