summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2005-11-22 18:36:21 (GMT)
committerBrad King <brad.king@kitware.com>2005-11-22 18:36:21 (GMT)
commitabebb974aa1983b4cbdd5a2d886908d735530694 (patch)
tree0df929908f21c6bafc04ceb3bb2b209749d00c04 /CMakeLists.txt
parent2dff0978b987b32bdc775b8920172d17b9750200 (diff)
downloadCMake-abebb974aa1983b4cbdd5a2d886908d735530694.zip
CMake-abebb974aa1983b4cbdd5a2d886908d735530694.tar.gz
CMake-abebb974aa1983b4cbdd5a2d886908d735530694.tar.bz2
COMP: Define _CRT_SECURE_NO_DEPRECATE to build CMake itself on VS8. This disables 1000s of deprecation warnings about standard code.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 040cf61..be6a5f4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,11 @@ IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
INCLUDE (${CMAKE_ROOT}/Modules/CMakeBackwardCompatibilityCXX.cmake)
ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
+# Disable deprecation warnings for standard C functions.
+IF(CMAKE_COMPILER_2005)
+ ADD_DEFINITIONS(-D_CRT_SECURE_NO_DEPRECATE)
+ENDIF(CMAKE_COMPILER_2005)
+
#silence duplicate symbol warnings on AIX
IF(CMAKE_SYSTEM MATCHES "AIX.*")
IF(NOT CMAKE_COMPILER_IS_GNUCXX)