summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-17 21:14:04 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-17 21:14:04 (GMT)
commitb507f8f0d1c1b678e1e9f01d2fd10a86bc4b5348 (patch)
tree76f27d2303656292b57a7e7d8129056755beb0c8 /CMakeLists.txt
parent84f1420d82e725cae6ca3873c52473046e4debef (diff)
downloadCMake-b507f8f0d1c1b678e1e9f01d2fd10a86bc4b5348.zip
CMake-b507f8f0d1c1b678e1e9f01d2fd10a86bc4b5348.tar.gz
CMake-b507f8f0d1c1b678e1e9f01d2fd10a86bc4b5348.tar.bz2
ENH: Simplify the test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 840c5c1..a2ef87b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,6 +125,10 @@ IF(BUILD_CursesDialog)
SUBDIRS(Source/CursesDialog/form)
ENDIF(BUILD_CursesDialog)
+INCLUDE(CheckSymbolExists)
+CHECK_SYMBOL_EXISTS(unsetenv "stdlib.h" HAVE_UNSETENV)
+CHECK_SYMBOL_EXISTS(environ "stdlib.h" HAVE_ENVIRON_NOT_REQUIRE_PROTOTYPE)
+
SUBDIRS(Source Modules Templates Utilities Tests/CMakeTests)
ENABLE_TESTING()