summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin Podsvirov <konstantin@podsvirov.pro>2016-08-04 10:01:42 (GMT)
committerKonstantin Podsvirov <konstantin@podsvirov.pro>2016-08-16 16:02:35 (GMT)
commitc18dc6fbe5b68312be52353aa0a493106584ffe7 (patch)
treeaef64221386463a3acc980f946b65a8f6292cbe5 /CMakeLists.txt
parent6b07972fbdf7e8687577a430597e40e7e0b4831d (diff)
downloadCMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.zip
CMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.tar.gz
CMake-c18dc6fbe5b68312be52353aa0a493106584ffe7.tar.bz2
Added CMake_BUILD_DEVELOPER_REFERENCE option
By default is OFF and marked as advanced. It's also add custom cmake-developer-reference (ALL) target Generated output will be installed to ${CMAKE_DOC_DIR}/developer-reference.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae5990e..3aef619 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,6 +93,11 @@ option(CMake_INSTALL_DEPENDENCIES
"Whether to install 3rd-party runtime dependencies" OFF)
mark_as_advanced(CMake_INSTALL_DEPENDENCIES)
+# option to build reference for CMake developers
+option(CMake_BUILD_DEVELOPER_REFERENCE
+ "Build CMake Developer Reference" OFF)
+mark_as_advanced(CMake_BUILD_DEVELOPER_REFERENCE)
+
#-----------------------------------------------------------------------
# a macro to deal with system libraries, implemented as a macro
# simply to improve readability of the main script