summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-01-07 15:07:49 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-01-08 19:35:23 (GMT)
commitc77281061c1b931842d5f0a03fc68b3f16999a5b (patch)
treed5088d25351629174c47188c7f729deded73d5d4 /CMakeLists.txt
parenta9f1bf438054227e989ad1706b785b978e18455c (diff)
downloadCMake-c77281061c1b931842d5f0a03fc68b3f16999a5b.zip
CMake-c77281061c1b931842d5f0a03fc68b3f16999a5b.tar.gz
CMake-c77281061c1b931842d5f0a03fc68b3f16999a5b.tar.bz2
Add the -Wundef flag when compiling CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ad9587..e84f898 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -588,10 +588,10 @@ if(NOT CMake_VERSION_IS_RELEASE)
NOT "${CMAKE_C_COMPILER_VERSION}" VERSION_LESS 4.2)
set(C_FLAGS_LIST -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts
-Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security
- -Wmissing-format-attribute -fno-common
+ -Wmissing-format-attribute -fno-common -Wundef
)
set(CXX_FLAGS_LIST -Wnon-virtual-dtor -Wcast-align -Wchar-subscripts -Wall -W
- -Wshadow -Wpointer-arith -Wformat-security
+ -Wshadow -Wpointer-arith -Wformat-security -Wundef
)
foreach(FLAG_LANG C CXX)