summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-01 19:21:45 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-01 19:21:45 (GMT)
commitce403305e170800a94c0f193ac3b463da5b21a9d (patch)
tree9ae60707f22776f2a2f40f115643d1b593638f1e /CMakeLists.txt
parent2a8adb53ea2ac15873a750e18198df3c14071f6e (diff)
downloadCMake-ce403305e170800a94c0f193ac3b463da5b21a9d.zip
CMake-ce403305e170800a94c0f193ac3b463da5b21a9d.tar.gz
CMake-ce403305e170800a94c0f193ac3b463da5b21a9d.tar.bz2
COMP: CMake should be build static. Also propagate build_shared_libs to curl
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c75cc6a..cc6e7eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,8 @@ SET(CMake_VERSION_PATCH 0)
SET(CMake_VERSION "${CMake_VERSION_MAJOR}.${CMake_VERSION_MINOR}")
SET(CMake_VERSION_FULL "${CMake_VERSION}.${CMake_VERSION_PATCH}")
+SET(BUILD_SHARED_LIBS OFF)
+
SET(CMAKE_DATA_DIR "/share/CMake" CACHE STRING
"Install location for data (relative to prefix).")
SET(CMAKE_DOC_DIR "/doc/CMake" CACHE STRING