summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-11-24 01:45:49 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-11-24 01:45:49 (GMT)
commite3c84cf5a6ceb3f1bbc4b47dce4dfbdb1c856408 (patch)
tree82a2ad082ba8b4d22deca15288c9daa679391b13 /CMakeLists.txt
parentd48ab19efe2daa4313e8bdcd626ffd556cb80fc3 (diff)
downloadCMake-e3c84cf5a6ceb3f1bbc4b47dce4dfbdb1c856408.zip
CMake-e3c84cf5a6ceb3f1bbc4b47dce4dfbdb1c856408.tar.gz
CMake-e3c84cf5a6ceb3f1bbc4b47dce4dfbdb1c856408.tar.bz2
ENH: add support for the Syllable OS (http://www.syllable.org)
major issues: -access() doesn't return false for an empty string (#ifdefed in cmake) -dlopen() doesn't return 0 on failure (#ifdefed in cmake and fixed now in Syllable) -the kwsys and Bootstrap tests fail with timeout due to the fact that I'm doing all that in qemu, which is quite slow -RPATH is now supported, so without modifying the test adapting DLL_PATH in Syllable is required for the tests to succeed -the Plugin test fails with an undefined reference to example_exe_function() in example_mod_1, it seems this isn't supported under Syllable Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 12 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee10117..59bcc30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,14 +319,19 @@ MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Use curses?
IF (UNIX)
- SET(CURSES_NEED_NCURSES TRUE)
- FIND_PACKAGE(Curses QUIET)
- IF (CURSES_LIBRARY)
- OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
- ELSE (CURSES_LIBRARY)
- MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be built.")
+ # there is a bug in the Syllable libraries which makes linking ccmake fail, Alex
+ IF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
+ SET(CURSES_NEED_NCURSES TRUE)
+ FIND_PACKAGE(Curses QUIET)
+ IF (CURSES_LIBRARY)
+ OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)
+ ELSE (CURSES_LIBRARY)
+ MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be built.")
+ SET(BUILD_CursesDialog 0)
+ ENDIF (CURSES_LIBRARY)
+ ELSE(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
SET(BUILD_CursesDialog 0)
- ENDIF (CURSES_LIBRARY)
+ ENDIF(NOT "${CMAKE_SYSTEM_NAME}" MATCHES syllable)
ELSE (UNIX)
SET(BUILD_CursesDialog 0)
ENDIF (UNIX)