summaryrefslogtreecommitdiffstats
path: root/Help/guide/tutorial/Step6/CMakeLists.txt
diff options
context:
space:
mode:
authorBetsy McPhail <betsy.mcphail@kitware.com>2019-07-09 23:28:57 (GMT)
committerBrad King <brad.king@kitware.com>2019-08-19 15:49:05 (GMT)
commitdf9cdf629c5211282dcab2e4751f69032e25a244 (patch)
treee8d780eedbfbeefc863db1e843834e4acf98e5f0 /Help/guide/tutorial/Step6/CMakeLists.txt
parent442c0f0d463d8f08a6c47b371cdb13a9ec4cea41 (diff)
downloadCMake-df9cdf629c5211282dcab2e4751f69032e25a244.zip
CMake-df9cdf629c5211282dcab2e4751f69032e25a244.tar.gz
CMake-df9cdf629c5211282dcab2e4751f69032e25a244.tar.bz2
Tutorial: Improve Step 5
* Updated output message * Use 'target_compile_definitions' for HAVE_LOG and HAVE_EXP Previously, the change from using TutorialConfig.h to target_compile_definitions happened without explanation as part of Step 8.
Diffstat (limited to 'Help/guide/tutorial/Step6/CMakeLists.txt')
-rw-r--r--Help/guide/tutorial/Step6/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/Help/guide/tutorial/Step6/CMakeLists.txt b/Help/guide/tutorial/Step6/CMakeLists.txt
index 2bb0859..c3b375a 100644
--- a/Help/guide/tutorial/Step6/CMakeLists.txt
+++ b/Help/guide/tutorial/Step6/CMakeLists.txt
@@ -10,12 +10,6 @@ set(CMAKE_CXX_STANDARD_REQUIRED True)
# should we use our own math functions
option(USE_MYMATH "Use tutorial provided math implementation" ON)
-# does this system provide the log and exp functions?
-include(CheckSymbolExists)
-set(CMAKE_REQUIRED_LIBRARIES "m")
-check_symbol_exists(log "math.h" HAVE_LOG)
-check_symbol_exists(exp "math.h" HAVE_EXP)
-
# configure a header file to pass some of the CMake settings
# to the source code
configure_file(TutorialConfig.h.in TutorialConfig.h)