summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-04-17 18:08:30 (GMT)
committerBrad King <brad.king@kitware.com>2007-04-17 18:08:30 (GMT)
commit0164f2faae22b002482adbfb1168af8712b8b3b8 (patch)
treeb4d873ef5c66af97ba1d022014aed4fa39045c9f /Source/CMakeLists.txt
parentc1a6e4dcc666c548c182bc6cf8617815b330d977 (diff)
downloadCMake-0164f2faae22b002482adbfb1168af8712b8b3b8.zip
CMake-0164f2faae22b002482adbfb1168af8712b8b3b8.tar.gz
CMake-0164f2faae22b002482adbfb1168af8712b8b3b8.tar.bz2
ENH: Added test for executables with plugins that use an API exported by the executable itself.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index f32ce0f..be55bb2 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -986,6 +986,16 @@ IF(BUILD_TESTING)
--test-command executable
)
+ ADD_TEST(Plugin ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Plugin"
+ "${CMake_BINARY_DIR}/Tests/Plugin"
+ --build-generator ${CMAKE_TEST_GENERATOR}
+ --build-project Plugin
+ --build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
+ --build-two-config
+ --test-command bin/example)
+
IF(NOT CMAKE_TEST_DIFFERENT_GENERATOR)
ADD_TEST(kwsys ${CMAKE_CTEST_COMMAND}
--build-and-test