summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-16 20:35:36 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-20 14:31:11 (GMT)
commit0238d0c397e52a82f20a0b7bf5aad9a07f36133c (patch)
tree1e63a6ae56817eb5808dfdd501d2fef67db9db63 /Source/CMakeLists.txt
parentbda4f0b661018b32aefdb14887d8137e7a4fd118 (diff)
downloadCMake-0238d0c397e52a82f20a0b7bf5aad9a07f36133c.zip
CMake-0238d0c397e52a82f20a0b7bf5aad9a07f36133c.tar.gz
CMake-0238d0c397e52a82f20a0b7bf5aad9a07f36133c.tar.bz2
cmake: Generate an internal 'Labels.json' file next to 'Labels.txt'
In each internal target directory we generate a "Labels.txt" file containing labels for that target and its sources, but it uses an internal format. In order to make the list of labels easier to publish, use a json format and call it "Labels.json". Since we now use jsoncpp headers, link CMakeLib to the jsoncpp library.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 96f4709..6b6008d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -500,7 +500,9 @@ add_library(CMakeLib ${SRCS})
target_link_libraries(CMakeLib cmsys
${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES}
${CMAKE_TAR_LIBRARIES} ${CMAKE_COMPRESS_LIBRARIES}
- ${CMAKE_CURL_LIBRARIES} )
+ ${CMAKE_CURL_LIBRARIES}
+ cmjsoncpp
+ )
# On Apple we need CoreFoundation
if(APPLE)