summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2023-08-21 13:49:24 (GMT)
committerKitware Robot <kwrobot@kitware.com>2023-08-21 13:49:48 (GMT)
commit0788accdfcd8f29b3853e7e1e91325515c62f1bd (patch)
treefc5338d4cba5928a4a675363dfd17b06b78eeaa6 /Source/CMakeLists.txt
parent355f658550d3432c29ddaf0d92aa048fa71b2d53 (diff)
parent48ee946fdcb8a610653e7ba42e9b8dba6942dbfb (diff)
downloadCMake-0788accdfcd8f29b3853e7e1e91325515c62f1bd.zip
CMake-0788accdfcd8f29b3853e7e1e91325515c62f1bd.tar.gz
CMake-0788accdfcd8f29b3853e7e1e91325515c62f1bd.tar.bz2
Merge topic 'imported-cxxmodules'
48ee946fdc cmExperimental: recycle the C++ modules API UUID 1a1806a71b gitlab-ci: declare `bmionly` support for modules where possible 457a12f3f9 Tests/RunCMake/CXXModules: add tests which use modules from imported targets 9b9ec70b54 Ninja: generate scanning and build rules for C++20 module synthetic targets 80ef50a191 CXXModules: add a variable for BMI-only compilation 80d6544398 cxxmodules: generate synthetic targets as an initial pass 3dc6676ecc cmSyntheticTargetCache: add a struct for synthetic target caching cb356b540c cmCxxModuleUsageEffects: add a class to capture module usage effects ... Acked-by: Kitware Robot <kwrobot@kitware.com> Tested-by: buildbot <buildbot@kitware.com> Merge-request: !8535
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index c40bfce..37d407b 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -171,6 +171,8 @@ add_library(
cmCustomCommandTypes.h
cmCxxModuleMapper.cxx
cmCxxModuleMapper.h
+ cmCxxModuleUsageEffects.cxx
+ cmCxxModuleUsageEffects.h
cmDefinitions.cxx
cmDefinitions.h
cmDependencyProvider.h
@@ -299,6 +301,8 @@ add_library(
cmGraphAdjacencyList.h
cmGraphVizWriter.cxx
cmGraphVizWriter.h
+ cmImportedCxxModuleInfo.cxx
+ cmImportedCxxModuleInfo.h
cmInstallGenerator.h
cmInstallGenerator.cxx
cmInstallGetRuntimeDependenciesGenerator.h
@@ -424,6 +428,7 @@ add_library(
cmStateTypes.h
cmStringAlgorithms.cxx
cmStringAlgorithms.h
+ cmSyntheticTargetCache.h
cmSystemTools.cxx
cmSystemTools.h
cmTarget.cxx