summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-08-21 16:37:40 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-08-21 16:37:40 (GMT)
commit07fa9ac09c69b098af08429eccaf332c15b97f1e (patch)
tree16afbc4be747a7a2bea3c7562b7e5b1833421271 /Source/CMakeLists.txt
parentba9c97ccec7496920981c918eba762f0a00c6ee2 (diff)
downloadCMake-07fa9ac09c69b098af08429eccaf332c15b97f1e.zip
CMake-07fa9ac09c69b098af08429eccaf332c15b97f1e.tar.gz
CMake-07fa9ac09c69b098af08429eccaf332c15b97f1e.tar.bz2
ENH: Implement TarCompress generator using compress library
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index e9221e5..f6770f8 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -19,6 +19,7 @@ INCLUDE_DIRECTORIES(
${CMAKE_ZLIB_INCLUDES}
${CMAKE_EXPAT_INCLUDES}
${CMAKE_TAR_INCLUDES}
+ ${CMAKE_COMPRESS_INCLUDES}
)
# let cmake know it is supposed to use it
@@ -217,7 +218,9 @@ ENDIF (WIN32)
# create a library used by the command line and the GUI
ADD_LIBRARY(CMakeLib ${SRCS})
-TARGET_LINK_LIBRARIES(CMakeLib cmsys ${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES} ${CMAKE_TAR_LIBRARIES})
+TARGET_LINK_LIBRARIES(CMakeLib cmsys
+ ${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES}
+ ${CMAKE_TAR_LIBRARIES} ${CMAKE_COMPRESS_LIBRARIES})
# On Apple we need Carbon
IF(APPLE)