summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Holtermann <sebholt@xwmw.org>2016-08-06 11:09:59 (GMT)
committerBrad King <brad.king@kitware.com>2016-08-10 17:21:33 (GMT)
commit0a5dd3c700f1873be217707aa89a805d009bac3e (patch)
tree46932c472df8f97ff38afb95e183f391f2423dd1 /Source/CMakeLists.txt
parent3a5f609cbb4ae63fca1eb87918767a4296d16e5f (diff)
downloadCMake-0a5dd3c700f1873be217707aa89a805d009bac3e.zip
CMake-0a5dd3c700f1873be217707aa89a805d009bac3e.tar.gz
CMake-0a5dd3c700f1873be217707aa89a805d009bac3e.tar.bz2
cmFilePathUuid: Add class to generate deterministic unique file names
The class generates a semi-unique (checksum based) pathless file name from a full source file path.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index a790994..cdc8fb1 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -238,6 +238,8 @@ set(SRCS
cmFileLockPool.h
cmFileLockResult.cxx
cmFileLockResult.h
+ cmFilePathUuid.cxx
+ cmFilePathUuid.h
cmFileTimeComparison.cxx
cmFileTimeComparison.h
cmFortranLexer.cxx