summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2016-09-09 08:01:46 (GMT)
committerTobias Hunger <tobias.hunger@qt.io>2016-09-29 19:47:05 (GMT)
commit0d96e1932937b866343ae8b52c20e0a8c058f3b2 (patch)
tree24c851e37aff55c8b0abbeaab92542df6a0696ec /Source/CMakeLists.txt
parent5d29506811c5b75ae48e12de6c317f6440874215 (diff)
downloadCMake-0d96e1932937b866343ae8b52c20e0a8c058f3b2.zip
CMake-0d96e1932937b866343ae8b52c20e0a8c058f3b2.tar.gz
CMake-0d96e1932937b866343ae8b52c20e0a8c058f3b2.tar.bz2
server-mode: Add infrastructure to watch the filesystem
Enable the server to watch for filesystem changes. This patch includes * The infrastructure for the file watching * makes that infrastructure available to cmServerProtocols * Resets the filesystemwatchers on "configure"
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index b8f02e3..bd237e4 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -780,6 +780,7 @@ target_link_libraries(cmake CMakeLib)
if(CMake_HAVE_SERVER_MODE)
add_library(CMakeServerLib
+ cmFileMonitor.cxx cmFileMonitor.h
cmServer.cxx cmServer.h
cmServerConnection.cxx cmServerConnection.h
cmServerProtocol.cxx cmServerProtocol.h