summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-16 20:26:39 (GMT)
committerBrad King <brad.king@kitware.com>2016-08-31 13:02:19 (GMT)
commit13b7e7587d50a52bb422852eb4d71a93eb8f18a6 (patch)
treedfcaef4dc5f2aef27c8473e6f8f4f1b15e4d6e60 /Source/CMakeLists.txt
parentd96416fe482e17bc9f5a741d71d4a51a9b44f65e (diff)
downloadCMake-13b7e7587d50a52bb422852eb4d71a93eb8f18a6.zip
CMake-13b7e7587d50a52bb422852eb4d71a93eb8f18a6.tar.gz
CMake-13b7e7587d50a52bb422852eb4d71a93eb8f18a6.tar.bz2
libuv: Build the library within CMake
Take logic from upstream `Makefile.am` and `configure.ac` to build libuv sources. Update `uv.h` to include KWSys Large File Support configuration so that consistent stream libraries are used (on AIX with XL). Add a `cm_uv.h` header to include the CMake-provided copy of the `uv.h` header from CMake sources.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3b94df7..8c74f60 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -582,6 +582,7 @@ target_link_libraries(CMakeLib cmsys
${CMAKE_TAR_LIBRARIES} ${CMAKE_COMPRESS_LIBRARIES}
${CMAKE_CURL_LIBRARIES}
${CMAKE_JSONCPP_LIBRARIES}
+ ${CMAKE_LIBUV_LIBRARIES}
${CMake_KWIML_LIBRARIES}
)