summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorNils Gladitz <nilsgladitz@gmail.com>2014-05-15 17:12:40 (GMT)
committerBrad King <brad.king@kitware.com>2014-05-28 16:28:18 (GMT)
commit15a8af21e8bd8354dfff2063e01f695f85efdeb8 (patch)
treeb7d98cab3ba63f61074a4f63a250934f0294826a /Source/CMakeLists.txt
parent032961c6ac81d82270a7b1986935111aa5e32a56 (diff)
downloadCMake-15a8af21e8bd8354dfff2063e01f695f85efdeb8.zip
CMake-15a8af21e8bd8354dfff2063e01f695f85efdeb8.tar.gz
CMake-15a8af21e8bd8354dfff2063e01f695f85efdeb8.tar.bz2
Add an "installed file" property scope
Teach set_property and get_property an "INSTALL" property type to be associated with install-tree file paths. Make the properties available to CPack for use during packaging. Add a "prop_inst" Sphinx domain object type for documentation of such properties.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 660c0c5..8ecf83c 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -163,6 +163,8 @@ set(SRCS
cmComputeLinkInformation.h
cmComputeTargetDepends.h
cmComputeTargetDepends.cxx
+ cmCPackPropertiesGenerator.h
+ cmCPackPropertiesGenerator.cxx
cmCryptoHash.cxx
cmCryptoHash.h
cmCustomCommand.cxx
@@ -243,6 +245,8 @@ set(SRCS
cmInstallGenerator.h
cmInstallGenerator.cxx
cmInstallExportGenerator.cxx
+ cmInstalledFile.h
+ cmInstalledFile.cxx
cmInstallFilesGenerator.h
cmInstallFilesGenerator.cxx
cmInstallScriptGenerator.h