summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-10-17 14:15:21 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2016-10-17 14:15:21 (GMT)
commit188c762f8a5f690708109a3cb8d44693e599adb1 (patch)
treeaccfc739aed26006b7f2ea813aac324caed11aa4 /Source/CMakeLists.txt
parent9a2048f1ea6687530e209992c3f5eafcbc02b2a9 (diff)
parentcef59bb8bac6b6d38025cc492235953c5ff7654b (diff)
downloadCMake-188c762f8a5f690708109a3cb8d44693e599adb1.zip
CMake-188c762f8a5f690708109a3cb8d44693e599adb1.tar.gz
CMake-188c762f8a5f690708109a3cb8d44693e599adb1.tar.bz2
Merge topic 'extract-computed-target-properties'
cef59bb8 cmTarget: Implement GetProperty in terms of cmState::Snapshot 0d57b07a cmTarget: Group code for checking written properties together c3fb0d95 cmTarget: Move sanity checks and computed property access to callers fa9dbc56 cmGeneratorTarget: Implement cmTargetPropertyComputer interface 848ae2a6 cmTargetPropertyComputer: Template some methods on the Target a0a720e6 cm{,Generator}Target: Add global generator accessors 637e3f3e cmTargetPropertyComputer: Unify whitelist handling from cmTarget 05251e6d cmTargetPropertyComputer: Move whitelist check from cmTarget fbf1721c cmTargetPropertyComputer: Extract into new files 390a7d86 cmTargetPropertyComputer: Implement GetProperty without cmMakefile e32a6bdd cmListFileBacktrace: Add a method to retrieve the Bottom of a snapshot 7863fba1 cmTarget: Extract GetLocation method 8096682e cmTarget: Extract GetSources method 7d57c1a2 cmTarget: Extract location computation methods a55cac4b cmTarget: Split property computation into separate class 705fcf52 cmTarget: Move IMPORTED check to callers ...
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 7d82a51..71892ba 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -364,6 +364,8 @@ set(SRCS
cmSystemTools.h
cmTarget.cxx
cmTarget.h
+ cmTargetPropertyComputer.cxx
+ cmTargetPropertyComputer.h
cmTargetExport.h
cmTest.cxx
cmTest.h