summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-01 00:30:57 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-16 13:22:35 (GMT)
commit25f2877eef3b876922c0e40053205026c8c00e7d (patch)
tree9ad520bc5c98f9edc931a86d2f2d358d5efb98f4 /Source/CMakeLists.txt
parent87cc62cab9fcfd2d870d81161643bb1cc1c1e2a2 (diff)
downloadCMake-25f2877eef3b876922c0e40053205026c8c00e7d.zip
CMake-25f2877eef3b876922c0e40053205026c8c00e7d.tar.gz
CMake-25f2877eef3b876922c0e40053205026c8c00e7d.tar.bz2
Add class cmRST to do basic reStructuredText processing
Create a cmRST class to perform just enough reStructuredText processing to support display of Help documents in human-readable text format. This will be used to implement --help-* command-line options. Support directives "include", "replace", "parsed-literal", "toctree" (Sphinx), and "cmake-module" (CMake Sphinx Extension to scan .cmake modules). Support inline CMake Sphinx Domain roles to convert cross-references to corresponding title text. Support inline substitutions defined by the "replace" directive, but keep it simple by requiring replacements to be defined before use. Add a CMakeLib "testRST" case to cover processing of supported constructs and compare results against expected output.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 3ec0e47..d549ccb 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -262,6 +262,8 @@ set(SRCS
cmPropertyMap.h
cmQtAutomoc.cxx
cmQtAutomoc.h
+ cmRST.cxx
+ cmRST.h
cmScriptGenerator.h
cmScriptGenerator.cxx
cmSourceFile.cxx