summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2019-04-30 15:29:30 (GMT)
committerKyle Edwards <kyle.edwards@kitware.com>2019-05-07 17:40:06 (GMT)
commit26025d6e106ffd4cd777fdc3a4343b33c8554c15 (patch)
treef40c983a734557f9137fa775fd051437079c89e4 /Source/CMakeLists.txt
parent6b04d1cdc281b9b0dee5f59394a1c41d8b96c4a1 (diff)
downloadCMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.zip
CMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.tar.gz
CMake-26025d6e106ffd4cd777fdc3a4343b33c8554c15.tar.bz2
cmUVProcessChain: Add cmUVProcessChain
This class is ultimately intended as a replacement for cmsys::Process. It spawns a series of processes using libuv, piping the output of each command into the next. Note: input support has not yet been implemented because write support has not yet been implemented on cmUVStreambuf.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 01c6cd7..42eed4d 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -388,6 +388,8 @@ set(SRCS
cmUuid.cxx
cmUVHandlePtr.cxx
cmUVHandlePtr.h
+ cmUVProcessChain.cxx
+ cmUVProcessChain.h
cmUVStreambuf.h
cmUVSignalHackRAII.h
cmVariableWatch.cxx