summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-20 15:31:13 (GMT)
committerBrad King <brad.king@kitware.com>2015-01-20 15:37:35 (GMT)
commit27c6da933ec1dd4028bb80e4adf2fa7309ef4a04 (patch)
tree40aa45aa6a35d21a8788191a04adc9851deb80dc /Source/CMakeLists.txt
parent17cfa09eb2a78349a6471e4719bc933dd0625d9e (diff)
downloadCMake-27c6da933ec1dd4028bb80e4adf2fa7309ef4a04.zip
CMake-27c6da933ec1dd4028bb80e4adf2fa7309ef4a04.tar.gz
CMake-27c6da933ec1dd4028bb80e4adf2fa7309ef4a04.tar.bz2
Add option to build CMake against a system jsoncpp
Create a CMAKE_USE_SYSTEM_JSONCPP option.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 435b654..af4c7cf 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -503,7 +503,7 @@ target_link_libraries(CMakeLib cmsys
${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES}
${CMAKE_TAR_LIBRARIES} ${CMAKE_COMPRESS_LIBRARIES}
${CMAKE_CURL_LIBRARIES}
- cmjsoncpp
+ ${CMAKE_JSONCPP_LIBRARIES}
)
# On Apple we need CoreFoundation