summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-06-16 17:18:21 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-06-16 17:18:21 (GMT)
commit2cc5ed49d17e5a26308d3af288767e7ef405903b (patch)
treea918403b8c04e6058785876c71e8b79cffd36948 /Source/CMakeLists.txt
parentb156314ab3cedc7fa1c8198a320be4a05dd6ff8d (diff)
downloadCMake-2cc5ed49d17e5a26308d3af288767e7ef405903b.zip
CMake-2cc5ed49d17e5a26308d3af288767e7ef405903b.tar.gz
CMake-2cc5ed49d17e5a26308d3af288767e7ef405903b.tar.bz2
ENH: Several improvements to CTest:
1. Support for showing line numbers when debugging ctest --show-line-numbers 2. Modify the ctest initialization code, so that it can be delayed 3. Handlers now have corresponding command if they were invoked from the command (so far only update actually use that) 4. Start command is simplified and the functionality is moved to CTest 5. Update can perform initial checkout if CTEST_CHECKOUT_COMMAND is set 6. Add test that checks out kwsys and perform tests on the fresh checkout
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 750ca1b..87813ee 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -802,7 +802,13 @@ IF(BUILD_TESTING)
"${CMake_BINARY_DIR}/Tests/CTestTest2/test.cmake" @ONLY ESCAPE_QUOTES)
ADD_TEST(CTestTest2 ${CMAKE_CTEST_COMMAND}
-S "${CMake_BINARY_DIR}/Tests/CTestTest2/test.cmake" -V
- --output-log "${CMake_BINARY_DIR}/Tests/CTestTest/testOutput.log"
+ --output-log "${CMake_BINARY_DIR}/Tests/CTestTest2/testOutput.log"
+ )
+ CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CTestTest3/test.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CTestTest3/test.cmake" @ONLY ESCAPE_QUOTES)
+ ADD_TEST(CTestTest3 ${CMAKE_CTEST_COMMAND}
+ -S "${CMake_BINARY_DIR}/Tests/CTestTest3/test.cmake" -V
+ --output-log "${CMake_BINARY_DIR}/Tests/CTestTest3/testOutput.log"
)
ENDIF (CTEST_TEST_CTEST AND CMAKE_RUN_LONG_TESTS)