summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2007-01-30 16:35:17 (GMT)
committerKen Martin <ken.martin@kitware.com>2007-01-30 16:35:17 (GMT)
commit49085f7fedfe467211129205349edaeb9b195a18 (patch)
tree3a5bdc8d6c50059d926e20ca7e1052b269cb3783 /Source/CMakeLists.txt
parentb32f3b4131294b0d4d8895cecf3bb2df11ff434c (diff)
downloadCMake-49085f7fedfe467211129205349edaeb9b195a18.zip
CMake-49085f7fedfe467211129205349edaeb9b195a18.tar.gz
CMake-49085f7fedfe467211129205349edaeb9b195a18.tar.bz2
BUG: fixes so that --build-and-test will honor timeouts
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ff26382..73676e4 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -383,6 +383,13 @@ IF(BUILD_TESTING)
OPTION(CMAKE_RUN_LONG_TESTS "Should the long tests be run (such as Bootstrap)." ON)
MARK_AS_ADVANCED(CMAKE_RUN_LONG_TESTS)
+ IF (CMAKE_RUN_LONG_TESTS)
+ OPTION(CTEST_TEST_CTEST
+ "Should the tests that run a full sub ctest process be run?"
+ OFF)
+ MARK_AS_ADVANCED(CTEST_TEST_CTEST)
+ ENDIF (CMAKE_RUN_LONG_TESTS)
+
ADD_TEST(CommandLineTest ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/CommandLineTest"
@@ -1071,6 +1078,10 @@ IF(BUILD_TESTING)
-S "${CMake_BINARY_DIR}/Tests/CTestTest3/test.cmake" -V
--output-log "${CMake_BINARY_DIR}/Tests/CTestTest3/testOutput.log"
)
+ # these tests take a log time, make sure they have it
+ SET_TESTS_PROPERTIES ( CTestTest CTestTest2 CTestTest3
+ PROPERTIES TIMEOUT 1500
+ )
ENDIF (CTEST_TEST_CTEST AND CMAKE_RUN_LONG_TESTS)
IF("${CMAKE_TEST_GENERATOR}" MATCHES Xcode)